oOracle - DB_BldTmplt - Could not get template information - System.Data.OracleClient requires Oracle client software version 8.1.7 or greater.

oOracle - DB_BldTmplt - Could not get template information - System.Data.OracleClient requires Oracle client software version 8.1.7 or greater.

Cause
Security permissions were not properly set when the Oracle client was installed on Windows with NTFS. The result of this is that content of the ORACLE_HOME directory is not visible to Authenticated Users on the machine; this causes an error while the System.Data.OracleClient is communicating with the Oracle Connectivity software from ASP.NET using Authenticated User privileges.

Solution
To fix the problem you have to give the Authenticated Users group privilege to the Oracle Home directory.
• Log on to Windows as a user with Administrator privileges.
• Start Window Explorer and navigate to the ORACLE_HOME folder.
• Choose properties on the ORACLE_HOME folder.
• Click the “Security” tab of the “Properties” window.
• Click on “Authenticated Users” item in the “Name” list.
• Un-check the “Read and Execute” box in the “Permissions” list under the “Allow” column.
• Re-check the “Read and Execute” box under the “Allow” column.
• Click the “Advanced” button and in the “Permission Entries” verify that “Authenticated Users” are listed with permission = “Read & Execute”, and Apply To = “This folder, subfolders and files”. If not, edit that line and make sure that “Apply To” drop-down box is set to “This folder, subfolders and files”. This should already be set properly but it is important that you verify it.
• Click the “Ok” button until you close out all of the security properties windows. The cursor may present the hour glass for a few seconds as it applies the permissions you just changed to all subfolders and files.
• Reboot, to assure that the changes have taken effect.
Try your application again.
    • Related Articles

    • System Health Alert for MEA&B Workflow

      There is a reoccurring problem with items getting left locked in the Import queue in the MEAB system. The problem is caused by the auto-indexing routines that attempt to use the Participant ID that is held in a barcode on certain document types: If ...
    • 404 error when viewing documentation and document separators in System Explorer

      In System Explorer directory view nodes, documents are delivered by being copied to the PDF virtual directory on the server and are then served up from there. The system uses a database table (tab_VDir) in the root database to hold mappings between ...